Neue Datenbank verlinkt Figuren nicht

Dieses Thema im Forum "Hilfe und Support" wurde erstellt von Pamina22, 25. März 2018.

  1. Pamina22

    Pamina22 Active Member

    Hallo, Leute!

    Ich möchte mir eine Tabelle mit Lebewesen erstellen, die genau wie die Figurendatenbank die Lebewesen in meiner Fantasy-Geschichte im Haupttext verlinkt. Aber irgendwas mache ich falsch.

    Ich habe in der neuen Tabelle eine Spalte mit Hauptname überschrieben, den Datentyp Autolink_Namen eingestellt und ebenfalls, dass die Eingabe zwingend ist.
    Dann habe ich das zweite Feld mit weitere_Namen bezeichnet und ebenfalls Autolink_Namen eingestellt. (Hier ist die Eingabe nicht zwingend.) Die übrigen Felder enthalten jeweils den Dateityp Text und einmal ist der Dateityp Bild eingestellt.
    Das Eingabeformular habe ich entsprechend eingerichtet und es ist auch bereit zur Eingabe meiner Daten. Aber wenn ich zum Haupttext wechsele und den Namen einer dieser Kreaturen schreibe, wird er nicht verlinkt.
    Ich habe nachgeschaut - die Tabelle Lebewesen wird im gleichen Ordner gespeichert wie die anderen Tabellen (Figuren, Dinge, Orte).
    Was könnte hier schiefgelaufen sein?

    LG
    Pamina
     
  2. AndreasB

    AndreasB Well-Known Member

    Moin Pamina

    Also, funktionieren kann das schon mal. Habe es ja selbst auch.
    Es müsste dann wie folgt aussehen.
    Zusatztabelle.png

    Wichtig hier. Die ROT markierten Tabellen sollten immer oben und auch in dieser Reihenfolge stehen.
    Ich habe noch drei weitere Tabellen darunter und auch eine 'Lebewesen'-Tabelle mit Autolinkfunktion in den Textbereich hinein.
    Eingestellt wie folgt.
    Zusatztabelle_2.png

    Bei solchen Zusatztabellen innerhalb der FigurenDB, solltest du allerdings auf eine 'Einmaligkeit' der Namensgebung achten. Ansonsten funktioniert es nicht immer wie erwartet. Es wird dann immer der zuerst gefundene Eintrag (Figuren, Orte, Dinge) gefunden und verlinkt.
     
    Lusmore, Ralf und neugierig gefällt das.
  3. dotpap

    dotpap Member

    Wenn dazu auch die Checkbox "Automatische Erzeugung von Figuren-Links" (Register "Volltextsuche") aktiviert ist. Im Auslieferungszustand ist sie deaktiviert.
     
    Lusmore, Waba und AndreasB gefällt das.
  4. Pamina22

    Pamina22 Active Member

    Hmm. Ich habe jetzt das Feld "alternative Namen" gelöscht, damit die Vergabe von Namen wirklich eindeutig ist. Das Verlinken klappt jetzt, aber so richtig zufrieden bin ich noch nicht.
    Das Programm erkennt den Link jetzt, wenn ich an den Namen der Kreatur ein Genitiv-s anhänge. Die Pluralbildung erfolgt jedoch bei einigen meiner Lebewesen durch das Anhängen eines "e". Und da erkennt Papyrus den Namen nicht mehr. Gleiches gilt für andere Fälle, z.B. für Dativ Plural.
    Papyrus erkennt also nur Nominativ und Akkusativ Singular und Genitiv Singular.
    Ist das normal? (Normalerweise hätte ich die verschiedenen grammatikalischen Formen als alternative Namen eingegeben. In den Tabellen "Figuren", "Dinge", "Orte" klappt das auch, aber hier anscheinend nicht.)

    Was bedeutet das genau? Sie ist aktiviert. Heißt das, dass die Verlinkung besser funktioniert, wenn ich das deaktiviere, oder funktioniert sie dann gar nicht mehr?

    LG
    Pamina
     
  5. AndreasB

    AndreasB Well-Known Member

    Damit meinte ich nur, dass der Name nirgends sonst in einer anderen Tabelle, als Autolink auftauchen sollte. Wenn er jedoch einmalig ist, kannst du auch alternative Namen eintragen. Nur eben auch hier auf Einmaligkeit bezüglich Autolinknamen in anderen Tabellen achten.
    Namen oder alternative Namen sollten, über alle Tabellen betrachtet, nicht mehrfach vorkommen.
    Ein Ein- und Ausschalter. Bei Zusatztabellen, die man mit Autolinkfunktion verwenden möchte, sollte das natürlich eingeschaltet sein.
     
  6. Pamina22

    Pamina22 Active Member

    Als Hauptname kommt der Name meiner Lebewesen in keiner anderen Tabelle vor. Wohl aber als Eintrag in den Figurendatenblättern der Tabelle Figuren. Gilt das auch? Kann es sein, dass die Verlinkung deshalb nicht funktioniert? Ich habe mir natürlich bei der Figurentabelle ein Feld mit dem Namen "Spezies" eingerichtet und trage dort ein, zu welcher Art Lebewesen die betreffende Figur gehört. Und das deckt sich dann mit der Tabelle Lebewesen ...
    Sobald ich das Feld "weitere Namen" gelöscht hatte, hat die Verlinkung funktioniert.

    LG
    Pamina
     
  7. dotpap

    dotpap Member

    Hallo.

    Ein weiterer Hinweis bezogen aufs manuelle Erzeugen von HyperOffice-Links (Text --> Datenbank):

    Wird der Standard Figuren-Datenbank, die schon mit dem Dokument (bzw. einem Projekt) korrekt verknüpft ist eine weitere DB-Tabelle z. B. "Lebewesen" hinzugefügt, dann sollte nach dem Hinzufügen der DB-Tabelle über Menü "Dokument" - "Verzeichnisse" - "Figuren-Datenbank" die Datenbank "Figuren.pb" erneut ausgewählt werden.
    Wird dies nicht getan, dann fehlt dieser Tabelleneintrag (z. B. Lebewesen) unter den Auflistungen im Menü "Dokument" - "Verzeichnisse" - hier dann: "Liste der Links in Lebewesen" und: "Report der Links in Lebewesen".
    Und natürlich auch im Kontextmenü (im Text) würde diese beiden "Tabellen-Einträge" (die man ja bspw. für das manuelle Verknüpfen Text --> Datenbank gebrauchen kann, auch nicht erscheinen. Das regelt auch kein Programm-Neustart!
     
  8. Pamina22

    Pamina22 Active Member

    Vielen Dank, dotpap, für den Hinweis.
    Aber so ganz hat das nicht geklappt. Ich habe jetzt wieder das Feld alternative Namen mit der Funktion Autolink_Namen eingerichtet, aber die angegebenen alternativen Namen verlinkt das Programm nicht, nur den normalen Namen und den mit Genitiv-s.
    Deinen Tipp mit Dokument - Verzeichnisse etc. funktioniert bei mir nicht, weil ich nach dem Auswählen der Datenbank "Figuren.pb" die Änderung nicht übernehmen kann. Die entsprechende Taste lässt sich nicht anklicken. Es sieht so aus, als hätte Papyrus gar nicht gemerkt, dass ich die Datenbank noch einmal ausgewählt. Was soll ich da machen?

    LG
    Pamina
     
  9. dotpap

    dotpap Member

    Hallo.

    Lass bitte Dein Datenbankprojekt beiseite. :)
    Und wir nehmen fürs Nachvollziehen ein Beispiel, was uns allen zur Verfügung steht.

    Kopiere doch mal das komplette Beispiel-Dokument "Findelkind".
    Es sollte bei vorgenommener Standardinstallation (unter Windows) hier liegen:
    C:\Program Files (x86)\Papyrus Autor\Beispiel-Dokumente\Findelkind

    Füge sie unter "Eigene Dokumente" ein - z. B. hier:
    C:\Users\ANWENDERNAME\Documents\Papyrus Autor\Findelkind

    Öffne "Findelkind.pap"
    Gehe mal zur Seite 31.
    Dort kommt die Figur "Kairon" drei Mal vor.

    Klicke doppelt auf "Kairon" im Dokument.
    Wähle Menü "Datenbank" - "Feldeigenschaften".
    Wähle Register "Volltextsuche"
    Deaktiviere die Checkbox "Automatische Erzeugung von Figuren-Links".
    Klicke auf Schalter "Tabelle anpassen" - "Anpassen".
    Gehe zurück in das zugehörige Dokument (z. B. durch Klick auf den Symbolschalter "Zum Dokument").
    Die HyperOfficeLinks rein zur Datenbank "Figuren.pb" - DB-Tabelle "Figuren" sind jetzt weg.
    Das betrifft übrigens nicht nur die Figur "Kairon", sondern auch alle anderen in "Findelkind.pap" genannten
    Figuren (z. B. Lorhien), die seinerzeit über das Datenbankfeld "Hauptname" der DB-Tabelle "Figuren" hinzugefügt wurden.

    Das Ganze kannst Du jetzt natürlich auch wieder rückgängig machen, indem Du die Checkbox "Automatische Erzeugung von Figuren-Links" der DB-Tabelle wieder aktivierst.
    Das funktioniert genau so auch mit der DB-Tabelle "Dinge" und Orte". Und auch mit weiteren DB-Tabellen z. B. "Lebewesen".

    Füge also der Datenbank "Figuren.pb" eine 4. Datenbank-Tabelle "Lebewesen" hinzu.
    Vergebe in ihr das erste und einzige Datenbankfeld. Man könnte es z. B: "LwHauptname" nennen.
    Weise diesem DB-Feld den Datentyp "Autolink-Namen".
    Achte darauf das die Checkbox "Automatische Erzeugung von Figuren-Links" aktiviert ist. Sie sollte es bereits sein.
    Klicke auf "Tabelle fertigstellen".
    Gebe einen ersten Datensatz ein. Als Wert könnte bspw. Eisengolem eingegeben werden.

    Gehe ins Dokument "Findelkind.pap".
    Menü "Dokument" - "Verzeichnisse" - "Figuren-Datenbank".
    Dort ist die Datenbank Figuren wie folgt eingetragen: "Figuren DB\Figuren.pb"
    Klicke auf "Auswählen...".
    Klicke auf Schließen".
    Speichern (Strg+S).

    Schreibe auf Seite 31 irgendwo das Wort Eisengolem und drücke dann Leertaste.
    Das Wort sollte nun in einen anklickbaren HyperOfficeLink umgewandelt worden sein.
    Stell die Einfügemarke in das Wort Eisengolem.
    Rechtsklick.
    Wähle "Sprung zum Datensatz in Lebewesen".

    Klicke auch mal der Vollständigkeit wegen auf die bereits verlinkte Figur Kairon.

    Berichte bitte, ob Du das alles so nachvollziehen kann.
    Oder an welchem Punkt kommst du evtl. in Stocken?

    Verfahre dann so mit deinem Projekt. Das muss funktionieren.
     
    Milar, Ralf und neugierig gefällt das.
  10. AndreasB

    AndreasB Well-Known Member

    Ich habe eben mal in meiner Tabelle einen bisher nicht vorhandenen Aliasnamen mit Autolink-Funktion hinzugefügt. Es funktioniert. Man muss darauf achten, wenn man mehrere Aliasnamen einträgt, diese durch ein Semikolon zu trennen. Damit sie für Papyrus vereinzelt zu erkennen sind.
    Im Textdokument werden sie automatisch verlinkt. Beobachten konnte dabei auch folgendes.
    Bei einem schon bestehenden Satz wurden sie erst verlinkt, wenn ich das Satzendzeichen (Punkt) gelöscht und neu gesetzt hatte. Das Beenden und neu Starten des Duden-Korrektors hilft da allerdings auch.
    Oder einen Satz neu schrieb.
     
    Zuletzt bearbeitet: 27. März 2018
  11. dotpap

    dotpap Member

    Nicht das Semikolon für die Trennung nehmen!
    Um mit der Papyrus-Hilfe deckungsgleich zu bleiben, wird dazu das Komma genutzt.
     
  12. AndreasB

    AndreasB Well-Known Member

    Ein Komma wäre in der Tat konform mit dem Handbuch. Allerdings bricht es bei mir die Kopfsache, dass man so Zahlenaneinanderreihungen nicht trennen sollte.
    Meinen Überlegungen nach, könnte daher in eine solch einer Wort-Aneinanderreihung, ein Komma problembehaftet für eine mögliche Weiterarbeitung sein. Ein Komma ist bei Zahlenwerten beispielsweise entweder Dezimaltrenner oder -Zähler - je nach Land. Mit einem Semikolon gab es hierbei niemals Probleme - daher nutze ich dieses instinktiv auch zum trennen von Wortaneinanderreihungen.
    Papyrus versteht es ja auch. Daher kam ich noch nicht auf die Idee, dort ein Komma zu nutzen.
     
  13. Pamina22

    Pamina22 Active Member

    Hallo, dotpap,
    vielen Dank für Deine ausführliche Erläuterung.
    Ich brauche etwas Zeit, um das umzusetzen und melde mich dann wieder.
    Bisher habe ich tatsächlich immer Kommas verwendet und kein Semikolon. Werde beides ausprobieren und berichten.
    Bin nur gerade unterwegs, deshalb könnte es ein paar Tage dauern. Mal sehen, wann ich Zeit finde.

    LG und danke!

    Pamina
     
  14. NowaksMario

    NowaksMario Member

    Hallo,

    ich bin neu hier und dachte mir, ich springe mal auf diesen Thread auf, da ich das selbe Problem habe. Ich muss auch sagen, so begeistert ich von Papyrus Autor auch bin - das Handbuch hat für meine Begriffe in fast jeder Hinsicht (Struktur, Aufbau, Stil, Inhalte ...) noch deutlichst Luft nach oben.

    Aber sei es, wie es sei, die Sache bei mir ist die: Ich konnte mit der Dinge-Datenbank in der vorgegebenen Form nicht viel anfangen. Da es einfacher war, eine neue Datenbank anzulegen, als das Eingabeformular zu bearbeiten, habe ich eine Datenbank angelegt, die (noch) den Namen "Dinge_neu" trägt. Deren Einträge werden aber nicht mit dem Dokument verknüpft. Wohl aber kann ich von der Datenbank aus eine Verknüpfung zu einem Begriff im Text herstellen. (Der wiederum wird dann aber nicht automatisch als richtig geschrieben angesehen, sondern bleibt rot unterschlängelt.)

    Außerdem habe ich eine Datenbank "Linguistik" angelegt (weil Fantasy-Geschichte mit entsprechend vielen "fremdsprachigen" Ausdrücken. Die wird aber überhaupt nicht verlinkt.

    Tja, und wie das so ist: Gerade, als ich Papyrus starten wollte, um meien Ausführungen hier etwas zu präzisieren, stelle ich fest: Statt wie sonst üblich das lezzte Dokument mit allen Datenbank-Reitern anzuzeigen, wurde mir ein neues, leeres Projekt angezeigt. Die Figuren-Datenbank zeigt nur noch die 22 (von 352) Datensätzen der im aktuellen vierten Band vorkommenden Figuren an, die anderen Datenbankreiter sind komplett weg. Was ist denn nun los?

    Liebe Grüße und Danke im Voraus,

    Mario
     
  15. NinaW

    NinaW Well-Known Member

    1. Datenbank != Tabelle, was von beidem hast du angelegt.

    Unter verschiedenen Umständen sieht Papyrus das letzte Projekt als wirklich geschlossen an und öffnet es nicht bei erneutem Start von Papyrus sondern öffnet ein neues Textdokument.
     
  16. NowaksMario

    NowaksMario Member

    Hallo Nina,

    ich habe Datenbanken angelegt. Zumindest glaube ich das, bin aber gerade vollends verwirrt. Wenn ich die verschiedenen Reiter mal wieder hergestellt habe, kann ich die Schritte hoffentlich noch mal im Einzelnen nachvollziehen.
     
  17. Ulli

    Ulli Administrator Mitarbeiter

    Einfach mit "letzte Dokumente" (unten im Menü "Datei") öffnen, was zuletzt geöffnet war, und in der Datenbank im Menü "Tabelle" aufrufen, was gewünscht ist.
    Papyrus stellt immer den letzten Zustand wieder her, in dem man es verlassen hat - also nicht alle Dateien / Reiter einzeln zuklicken, sonst wird natürlich nur das letzte offene Dokument beim Neustart wieder angezeigt - einfach das ganze Fenster zu, dann öffnet's sich auch wieder so.

    Da ist nichts Verwirrendes dabei, Papyrus macht genau, was man selbst so einstellt / wie man es verlässt.
     
  18. NinaW

    NinaW Well-Known Member

    Ich würde wirklich erstmal damit anfangen in die Tabelle(!) Dinge der Datenbank FigurenDB.pf(? - habs grad nicht vor mir und rate) zu wechseln und einfach diese Tabelle um die Spalten zu erweitern, die du brauchst. Damit erweitert sich automatisch(!) auch das Eingabeformular der Dinge und du musst das dann eigentlich nur noch bearbeiten, wenn du Felder darin formatieren möchtest. Also nur noch für die Schönheit, nicht für die Funktion.

    Wenn es dein erstes Mal mit der Datenbank ist, würde ich auch wirklich empfehlen nicht gleich alles ganz anders und neu zu machen, denn wie bei so vielen Dingen, die man zum ersten Mal macht, ist das erste davon nicht immer das ... qualitativ herausstechendste.
     
  19. NowaksMario

    NowaksMario Member

    Hallo Ulli,

    danke schon mal für deine Antwort. Und, doch: Es ist verwirrend. ;) Habe gerade noch mal in mich hineingehorcht, und das Gefühl ist tatsächlich eins der Verwirrung. Ich bin mir nämlich nicht bewusst, dass ich das Programm in irgendeiner Weise anders geschlossen hätte als sonst - was nicht heißt, dass ich es nicht getan hätte. Ich gehe auch davon aus, dass irgendwo im Handbuch von Papyrus Autor/Papyrus Base genau und verständlich beschrieben wird, wie man neue Datenbanken anlegt und auch einbindet. Aber im Moment wundert's mich ehrlich gesagt schon, dass ich die oben von AndreasB und dotpap beschriebenen Tipps bzw. Vorgehensweisen so im handbuch nicht finde.

    Immerhin: Figurendatanbenk ist komplett wieder da, Orte-Datenbank und Dinge-Datenbank auch. Datenbanken "Dinge_neu" und "Linguistik" sind auch unter den zuletzt geöffneten Dokumenten nicht zu finden.

    Danke und Gruß,

    Mario
     
  20. NinaW

    NinaW Well-Known Member

    Datenbanken würden da eh nicht zu finden sein, sondern nur deine Projektdokumente aka Textdokumente. Die Datenbank (allgemein Figuren-Datenbank genannt) muss im Projekt unter "verknüpfte Dokumente" eingefügt werden (und es kann nur eine Datenbank für ein Projekt geben), damit sie einem Projekt zugeordnet ist.
    Benutze eine Tabelle (eine Datenbank kann aus vielen Tabellen bestehen) und keine Datenbank, sonst musst du dich für Figuren oder Dinge_neu entscheiden.

    Doku findet man auch hier:
    https://www.papyrus.de/wiki/feldeigenschaften-veraendern-art-beschreibung-anzahl-datenfelder/
    https://www.papyrus.de/wiki/der-datenbankteil-von-papyrus-papyrus-base/
     
    Zuletzt bearbeitet: 5. April 2018
    SaschaCE gefällt das.