Paste vom Clipboard verschluckt Zeilenumbrüche

Dieses Thema im Forum "Hilfe und Support" wurde erstellt von Kana, 10. Januar 2020.

  1. Kana

    Kana New Member

    Hi zusammen,

    wenn ich einen Text vom Clipboard nach Papyrus (Windows Version) kopiere, werden die Zeilenenden verschluckt.
    Einstellungen.ImExport.ASCII, "Fließtext" und die zwei folgenden Optionen sind deaktiviert.

    Hier ein Beispiel: dieser Text

    /** @file crc.h
    *
    * @brief Compact CRC library for embedded systems for CRC-CCITT, CRC-16, CRC-32.
    *
    * @par


    sieht nach dem Pasten in Papyrus so aus:
    2020-01-10 14_02_34-Window.png


    Alle anderen Programme (Notepad++, Word, Editor) pasten korrekt.
    Sitze ich auf dem Schlauch, ist ja doch eine Basisfunktionalität!?
     
    Zuletzt bearbeitet: 10. Januar 2020
  2. caseelse

    caseelse New Member

    Hm, ich hab's grade mit dem gleichen Textschnipsel probiert, und das hat funktioniert.
    Bei mir ist die von dir genannte Option „Fließtext“ aktiviert, die folgenden beiden aber nicht.
     
  3. Kana

    Kana New Member

    Ich glaube, ich hab's rausgefunden. Scheint ein Bug zu sein, wo das Setting Fließtext immer aktiviert ist, egal, ob man das Häkchen setzt oder nicht.
    Das Problem am Text oben ist, dass die Forumssoftware Leerzeichen am Zeilenende entfernt, das ist aber genau der Trigger für die Fließtext Option.

    Wenn man also
    abcd_
    efgh
    in einen externen ASCII Editor (nicht in Papyrus) eingibt (wobei der endständige Unterstrich durch ein Leerzeichen ersetzt werden muss), dann das ganze kopiert und in Papyrus einfügt, dann bekommt man
    abcd efgh
    statt das Ganze in zwei Zeilen.

    PS: Version Papyrus 10.00 W64 vom 19.12.2019
     
  4. Ulli

    Ulli Administrator Mitarbeiter

    Das ist kein Bug, das ist Absicht bzw. einstellbar ... (Einstellungen -> ASCII). Grund ist, dass viele ASCII-Texte unsinnigerweise nach jeder Zeile eine Leerzeile haben, was natürlich unerwünscht ist.
     
  5. Kana

    Kana New Member

    Du hast das
    gesehen? Das Verhalten lässt sich nicht beeinflussen, habe es unter Win64 ausprobiert.